読者です 読者をやめる 読者になる 読者になる

clock-up-blog

go-mi-tech

gem

Windowsでの「extconf.rb:104:in `makemakefiles': unhandled exception」対処

Windows で gem install しようとしたときに出てくるコレへの対処 エラー例 gem install knife-solo しようとしたときとか。 > gem install knife-solo … Fetching: coderay-1.1.0.gem (100%) Successfully installed coderay-1.1.0 Fetching: pry-0.10.3.ge…

gem install mecab でビルドエラー

gem install mecab で cpp のコンパイルエラー # yum -y install mecab mecab-devel install mecab-ipadic # gem install mecab Building native extensions. This could take a while... ERROR: Error installing mecab: ERROR: Failed to build gem native…

(Windows) Ruby2.0 on Rails "incompatible library version"

概要 Windows 上の Ruby2.0 on Rails にて。 > rake db:migrate rake aborted! incompatible library version - C:/RailsInstaller/Ruby2.0.0/lib/ruby/gems/2.0.0/gems/bcrypt-ruby-3.1.1-x86-mingw32/lib/bcrypt_ext.soなんだか見たことのあるエラー。 関…

(Windows) Ruby2.0 on Rails で SQLite3 にハマらない手順

概要 railsが使いたい。 ruby2.0が使いたい。 RailsInstaller に Ruby2.0.0対応版(アルファ版)がある!これを導入しよう。しかし sqlite3 の罠があった。 (おそらく)ハマらない手順まとめ railsinstaller-3.0.0.exe デフォルト選択肢でインストール (C:\Rail…

});